Forums

Versão completa: WebServices para govdigital na cidade de Bragança Paulista
Você está visualizando uma versão simplificada de nosso conteúdo. Ver versão completa com a formatação apropriada.
Páginas: 1 2
Boa noite.

Quais webservices devem ser utilizados para cidade de Bragança Paulista ?

Tem exemplos de xml´s de envio, estive observando que de acordo com cada cidade, existem algumas diferenças entre cada uma delas.

Obrigado.

Alexandre.
A documentação referente às integrações via webservices encontram-se em https://govdigital.jira.com/wiki/pages/viewpage.action?pageId=12648453

Observe que Bragança Paulista não tem endpoint configurado. Vou entrar em contato com o fisco local para solicitar que eles comprem os certificados necessários para integração.

Para gerar a demanda necessária solicito que você também entre em contato com a fiscalização local e solicite a eles a possibilidade de integração via webservices informando quais os contribuintes serão atendidos pela sua empresa

Grato
ok. Obrigado.
(12-05-2015, 10:56 AM)lucas Escreveu: [ -> ]A documentação referente às integrações via webservices encontram-se em https://govdigital.jira.com/wiki/pages/viewpage.action?pageId=12648453

Observe que Bragança Paulista não tem endpoint configurado. Vou entrar em contato com o fisco local para solicitar que eles comprem os certificados necessários para integração.

Para gerar a demanda necessária solicito que você também entre em contato com a fiscalização local e solicite a eles a possibilidade de integração via webservices informando quais os contribuintes serão atendidos pela sua empresa

Grato

Bom dia! Saberiam me informar se isso já foi resolvido? Eles já tem o endpoint configurado?
Atualizei a documentação com os Endpoints novos.

Em homologação ja estão ok.
Em produção estará ok em 2 ou 3 dias.
Gostaria de saber se o webservice de Bragança Paulista já está funcionando ?

Estou realizando testes com o endpoint de homologação mas não consigo comunicação e me retorna a mensagem:
"O esquema URI do provedor HTTPS é inválido"

Quando tento utilizando apenas HTTP me retorna a resposta:
<?xml version="1.0" encoding="UTF-8" standalone="true"?>
-<ns2:GerarNfseResposta xmlns:ns2="http://www.abrasf.org.br/nfse.xsd" xmlns="http://www.w3.org/2000/09/xmldsig#">
-<ns2:ListaMensagemRetorno>
-<ns2:MensagemRetorno>
<ns2:Codigo>GOV38</ns2:Codigo>
<ns2:Mensagem>Endpoint de webservice sem SSL.</ns2:Mensagem>
<ns2:Correcao>Utilize httpS para enviar os arquivos webservice.</ns2:Correcao>
</ns2:MensagemRetorno>
</ns2:ListaMensagemRetorno>
</ns2:GerarNfseResposta>

Como posso resolver ?
Sim
Ja esta funcionando.
Sem o S do httpS o serviço não deve funcionar mesmo.

Em homolog o acesso é permitido para facilitar a geração de clientes, porém a chamada de serviços sem o SSL não é válido
A solução é fazer a chamada utilizando httpS conforme especificação
Quando utilizo HTTPS retorna a mensagem:

"O esquema URI do provedor HTTPS é inválido"

Você imagina o pode ser ?
Alguém tem alguma dica para a questão da Monica acima ?
Quando utilizo HTTPS retorna a mensagem:

"O esquema URI do provedor HTTPS é inválido"

Alguém imagina o que pode ser?

Preciso de uma solução para implantar no meu cliente
Páginas: 1 2