Forums
Erro Prefeitura Araguari - Versão para Impressão

+- Forums (http://forum.sonner.com.br)
+-- Fórum: GovDigital (http://forum.sonner.com.br/forumdisplay.php?fid=1)
+--- Fórum: Web Services (http://forum.sonner.com.br/forumdisplay.php?fid=2)
+--- Tópico: Erro Prefeitura Araguari (/showthread.php?tid=59)

Páginas: 1 2


Erro Prefeitura Araguari - dev03 - 10-09-2015

Código:
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<GerarNfseResposta xmlns="http://www.abrasf.org.br/nfse.xsd" xmlns:ns2="http://www.w3.org/2000/09/xmldsig#">
  <ListaMensagemRetorno>
    <MensagemRetorno>
      <Codigo>GOV12</Codigo>
      <Mensagem>org.hibernate.exception.SQLGrammarException: could not extract ResultSet</Mensagem>
      <Correcao>Contate a prefeitura e reporte o problema.</Correcao>
    </MensagemRetorno>
  </ListaMensagemRetorno>
</GerarNfseResposta>



RE: Erro Prefeitura Araguari - lucas - 10-09-2015

Por favor tente nova submissão.


RE: Erro Prefeitura Araguari - marcello - 17-09-2015

Lucas pode me ajudar com esse erro?

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ns2:GerarNfseResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd">
   <ns2:ListaMensagemRetorno>
       <ns2:MensagemRetorno>
           <ns2:Codigo>GOV38</ns2:Codigo>
           <ns2:Mensagem>Endpoint de webservice sem SSL.</ns2:Mensagem>
           <ns2:Correcao>Utilize httpS para enviar os arquivos webservice.</ns2:Correcao>
       </ns2:MensagemRetorno>
   </ns2:ListaMensagemRetorno>
</ns2:GerarNfseResposta>

O WebService de homologação que me foi passado é: http://homolog.govdigital.com.br/ws/arag?wsdl


RE: Erro Prefeitura Araguari - lucas - 18-09-2015

usa
httpS:// .....


RE: Erro Prefeitura Araguari - marcello - 18-09-2015

Lucas, não funciona com o webservice:
httpS://homolog.govdigital.com.br/ws/arag?wsdl

Tem alguma outra forma, pois uma pessoa ligada a vocês que pediu para eu fazer pelo http://homolog.govdigital.com.br/ws/arag?wsdl (Jocimar).

Obrigado pela atenção.


RE: Erro Prefeitura Araguari - dev03 - 22-09-2015

(18-09-2015, 05:49 PM)marcello Escreveu:  Lucas, não funciona com o webservice:
httpS://homolog.govdigital.com.br/ws/arag?wsdl

Tem alguma outra forma, pois uma pessoa ligada a vocês que pediu para eu fazer pelo http://homolog.govdigital.com.br/ws/arag?wsdl (Jocimar).

Obrigado pela atenção.

Marcello qual linguagem vc está usando ?

aqui no meu visual studio 2015 funciona perfeitamente

abraço


RE: Erro Prefeitura Araguari - marcello - 28-09-2015

O meu é o VS 2013, mas não vai, tenho que estar com um certificado digital ativo pra acessar esse HTTPs?

Segue as telas.


RE: Erro Prefeitura Araguari - lucas - 28-09-2015

dev.
Para bater no httpS vc precisa ter o certificado na requisição. Senão receberá o erro de ssl


RE: Erro Prefeitura Araguari - marcello - 28-09-2015

Obrigado Lucas, vou fazer o teste com o certificado instalado.

Obs.: Me passaram orientação para utilizar o http que era justamente para não precisar do certificado enquanto fazia homologação, só perdi um tempo.


RE: Erro Prefeitura Araguari - dev03 - 28-09-2015

Eu tenho o certificado do cliente instalado na minha maquina

e como o web service é em java eu uso o modo advance ai em baixo na tela das referências

e na hora de instanciar eu passo o serial do certificado no objeto

funciona perfeitamente em produção e homologação

agora to sem tempo para mandar os códigos

mas quando terminar uma tarefa aqui preparo um tutorial com imagens