Forums
Erro GOV12 - Versão para Impressão

+- Forums (http://forum.sonner.com.br)
+-- Fórum: GovDigital (http://forum.sonner.com.br/forumdisplay.php?fid=1)
+--- Fórum: Web Services (http://forum.sonner.com.br/forumdisplay.php?fid=2)
+--- Tópico: Erro GOV12 (/showthread.php?tid=879)



Erro GOV12 - FabioDevFT - 03-12-2018

Bom dia, ao realizar uma consulta de NFse da prefeitura de Guaxupé-MG é retornado o seguinte erro:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ConsultarNfseRpsResposta xmlns="http://www.abrasf.org.br/nfse.xsd" xmlns:ns2="http://www.w3.org/2000/09/xmldsig#">
   <ListaMensagemRetorno>
       <MensagemRetorno>
           <Codigo>GOV12</Codigo>
           <Mensagem>Erro inesperado atendendo solicitação.</Mensagem>
           <Correcao>Contate a prefeitura e reporte o problema.</Correcao>
       </MensagemRetorno>
   </ListaMensagemRetorno>
</ConsultarNfseRpsResposta>

Isso esta ocorrendo tanto em ambiente de homologação quanto em ambiente de produção.

Poderiam verificar por gentileza?

Segue em anexo o xml da consulta


RE: Erro GOV12 - Hiago - 04-12-2018

Bom dia,

Qual acredito que esteja utilizando o serviço de consulta inválido.
Favor validar se o serviço utilizado é o ConsultarNfsePorRps.


att,
Hiago


RE: Erro GOV12 - FabioDevFT - 05-12-2018

Boa tarde Hiago, o serviço que esta sendo usado é o ConsultarNfsePorRps


RE: Erro GOV12 - Hiago - 06-12-2018

Boa tarde Fabio,

Tente tira o trecho abaixo do XML de envio por favor.

Código:
<?xml version="1.0" encoding="utf-8"?>

att,
Hiago


RE: Erro GOV12 - FabioDevFT - 10-12-2018

Bom dia Hiago, fiz um teste conforme a orientação passada e desse modo o WebService reporta um erro de validação do xml:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ns2:ConsultarNfseRpsResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd">
<ns2:ListaMensagemRetorno>
<ns2:MensagemRetorno>
<ns2:Codigo>GOV13</ns2:Codigo>
<ns2:Mensagem>Erro de validação do xml segundo o schema.</ns2:Mensagem>
<ns2:Correcao>Valide o xml segundo o schema fornecido no manual.</ns2:Correcao>
</ns2:MensagemRetorno>
</ns2:ListaMensagemRetorno>
</ns2:ConsultarNfseRpsResposta>


RE: Erro GOV12 - Hiago - 11-12-2018

Bom dia Fabio,

Pelo que eu vi, o envio foi feito da mesma forma. Teria como enviar sem o cabeçalho "<?xml version="1.0" encoding="utf-8" standalone="yes"?>"?


att,
Hiago