Avaliação do Tópico:
  • 0 Voto(s) - 0 em Média
  • 1
  • 2
  • 3
  • 4
  • 5
Erro de layout para ConsultarNfseRps
#1
Caros estou com duas dificuldade.
1. Não consigo contato com o pessoal da IGAM/SONNER Pelotas nos telefones indicados

2. Estou tentando no ambiente de homologação enviar xml de ConsultarNfseRps mas retorna sempre erro:
- Montei um pelo programa ERP proprio ERRO
- Peguei um que o pessoal usa como padrão: ERRO
- Alterei para dados de Pelotas : ERRO

xml de teste(Homologação:
<ConsultarNfseRpsEnvio>
<IdentificacaoRps>
<Numero>2</Numero>
<Serie>1</Serie>
<Tipo>2</Tipo>
</IdentificacaoRps>
<Prestador>
<Cnpj>12345612312</Cnpj>
<InscricaoMunicipal>2135465</InscricaoMunicipal>
</Prestador>
</ConsultarNfseRpsEnvio>

Mensagem de erro:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ns2:ConsultarNfseRpsResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd">
<ns2:ListaMensagemRetorno>
<ns2:MensagemRetorno>
<ns2:Codigo>GOV13</ns2:Codigo>
<ns2:Mensagem>Erro de validação do xml segundo o schema.</ns2:Mensagem>
<ns2:Correcao>Valide o xml segundo o schema fornecido no manual.</ns2:Correcao>
</ns2:MensagemRetorno>
</ns2:ListaMensagemRetorno>
</ns2:ConsultarNfseRpsResposta>
Responder
#2
Bom dia,

Tenta adicionando a TAG CpfCnpj por favor.

<ConsultarNfseRpsEnvio>
<IdentificacaoRps>
<Numero>2</Numero>
<Serie>1</Serie>
<Tipo>2</Tipo>
</IdentificacaoRps>
<Prestador>
<CpfCnpj>
<Cnpj>12345612312</Cnpj>
</CpfCnpj>
<InscricaoMunicipal>2135465</InscricaoMunicipal>
</Prestador>
</ConsultarNfseRpsEnvio>

att,
Hiago
Responder
#3
Feito a alteração dá o mesmo erro. abaixo o xml de envio alterado e o xml de resposta:


Homologação
Envio:
<?xml version="1.0" encoding="utf-8"?>
<ConsultarNfseRpsEnvio>
<IdentificacaoRps>
<Numero>78</Numero>
<Serie>1</Serie>
<Tipo>2</Tipo>
</IdentificacaoRps>
<Prestador>
<CpfCnpj>
<Cnpj>92219559000125</Cnpj>
</CpfCnpj>
<InscricaoMunicipal>5137969</InscricaoMunicipal>
</Prestador>
</ConsultarNfseRpsEnvio>
<!-- origin3.grp.bf1.yahoo.com Wed Apr 12 17:38:11 UTC 2017 -->

<!-- origin3.grp.bf1.yahoo.com Wed Apr 12 17:38:11 UTC 2017 -->

Resposta:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ns2:ConsultarNfseRpsResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd">
<ns2:ListaMensagemRetorno>
<ns2:MensagemRetorno>
<ns2:Codigo>GOV13</ns2:Codigo>
<ns2:Mensagem>Erro de validação do xml segundo o schema.</ns2:Mensagem>
<ns2:Correcao>Valide o xml segundo o schema fornecido no manual.</ns2:Correcao>
</ns2:MensagemRetorno>
</ns2:ListaMensagemRetorno>
</ns2:ConsultarNfseRpsResposta>


Obs.: Tu fez o teste enviando para o homolagação de PELOTAS/RS ou é apenas o padrão que me passou?

Paulo
Responder
#4
Boa tarde,

Passei apenas o padrão, você consegue anexar o XML com assinatura para que eu possa fazer alguns testes?

att,
Hiago
Responder
#5
sim,

<?xml version="1.0" encoding="UTF-8"?>
<Validacao>
<cStat>1</cStat>
<xMotivo>XML assinado e validado com sucesso.</xMotivo>
</Validacao>

A validação retorna o xml mas não tem assinatura no corpo da resposta.
Se necessário te envio Nfse gerada agora em homologação, abaixo o código de verificação:
<CodigoVerificacao>1fl2b25ftmylo1oe0tygyzjcwhvmemvbr1dwt5b3bxzhqejbnn</CodigoVerificacao>



Paulo,
Responder


Pular para Fórum:


Usuários visualizando este tópico: 1 Visitante(s)