Avaliação do Tópico:
  • 0 Voto(s) - 0 em Média
  • 1
  • 2
  • 3
  • 4
  • 5
DIVINOPOLIS: Erro <E183> ao cancelar uma nota
#1
Boa tarde,

Ao efetuar o cancelamento utilizando o serviço CancelarNfse, recebi o seguinte erro:

<outputXML>
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><CancelarNfseResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd"> <ListaMensagemRetorno> <MensagemRetorno> <Codigo>E183</Codigo> <Mensagem>A mensagem XML do cabeçalho do arquivo enviado está fora do padrão especificado.</Mensagem> <Correcao>Consulte o Manual da NFS-e para saber quais são as versões de XML Schema suportadas pelo sistema.</Correcao> </MensagemRetorno> </ListaMensagemRetorno></CancelarNfseResposta>
</outputXML>

Fiz uma conferencia no arquivo enviado mas não consegui identificar o problema.

Segue em anexo, o XML que enviei de cancelamento (cancelarnfse_soap.xml) e o xml contendo a mensagem de erro (retorno_nfse.xml).

Desde já agradeço à atenção.

Cássia


Arquivos Anexados
.xml   cancelarnfse_soap.xml (Tamanho: 4,87 KB / Downloads: 32)
.xml   retorno_nfse.xml (Tamanho: 799 bytes / Downloads: 3)
Responder
#2
Bom dia a todos,

Alguém teria alguma orientação para me passar sobre esse tópico ?

Desde já agradeço à atenção.

Cássia
Responder
#3
O xml de cabeçalho está inválido. O namespace xmlns está declarado duas vezes uma vez com o namespace do desig, outro do xsd da abrasf.


Código:
<CancelarNfseResposta xmlns="http://www.w3.org/2000/09/xmldsig#" xmlns:ns2="http://www.abrasf.org.br/nfse.xsd">
Responder
#4
Lucas, novamente obrigada pela ajuda.
Fiz algumas alterações no meu XML e obtive outra resposta:

<outputXML>
<?xml version="1.0" encoding="UTF-8" standalone="yes"?><CancelarNfseResposta xmlns="http://www.abrasf.org.br/nfse.xsd" xmlns:ns2="http://www.w3.org/2000/09/xmldsig#"> <ListaMensagemRetorno> <MensagemRetorno> <Codigo>GOV12</Codigo> <Mensagem>Erro inesperado atendendo solicitação.</Mensagem> <Correcao>Contate a prefeitura e reporte o problema.</Correcao> </MensagemRetorno> </ListaMensagemRetorno></CancelarNfseResposta>
</outputXML>


Acredito que o problema esteja nos dados que tenho enviado ao webservice. Dessa forma irei iniciar os testes no ambiente de homologação direto no cliente.
Mas em relação a primeira mensagem enviada acredito que esse TÓPICO esteja RESOLVIDO.

Obrigada mais uma vez pela atenção.

TÓPICO RESOLVIDO.
Responder


Pular para Fórum:


Usuários visualizando este tópico: 1 Visitante(s)